Troubleshooting

A list of common issues that you may run into when making a POST or GET request to the MailUp API.

For details on the parameters to pass in those requests, please see this page.

Issue

Likely cause

Custom data fields are not handled correctlyMake sure that the field code is being used (Campo1, Campo2, etc.) instead of the field name (e.g. UserName).

The recipient is subscribed, but remains among pending contacts, even though I do not use a confirmation request

Likely, some of the parameters are not passed correctly.

For example, make sure that the different fields are passed as "Campo1", "Campo2", "CampoN" and not with the field names used in the console. To map lists and groups and match them to the correct IDs check the page Settings > Codes Table and List GUID in the MailUp console.

Calls to xmlSubscribe.aspx systematically return errors

Check that the caller IP address has been registered: if not, it must be added to the list available on the page Manage > Web Services (select "Manage > WebServices > FrontEnd")

Calls to UpdateSubscriber.aspx return an errorMake sure that you specify the ListGuid and not just the list ID. Click here for more details.